IANA special-purpose registries

Addresses that never reach the internet, and what they mean.

If an address on your screen starts with 192.168, 10, 100.64, 127 or fe80, it is one of these. Each page says what the block is for and what to do about it.

IPv4

0.0.0.0/8This network · RFC 791, Section 3.2
0.0.0.0/32This host on this network · RFC 1122, Section 3.2.1.3
10.0.0.0/8Private-Use · RFC 1918
100.64.0.0/10Shared Address Space · RFC 6598
127.0.0.0/8Loopback · RFC 1122, Section 3.2.1.3
169.254.0.0/16Link Local · RFC 3927
172.16.0.0/12Private-Use · RFC 1918
192.0.0.0/24IETF Protocol Assignments · RFC 6890, Section 2.1
192.0.0.0/29IPv4 Service Continuity Prefix · RFC 7335
192.0.0.8/32IPv4 dummy address · RFC 7600
192.0.0.9/32Port Control Protocol Anycast · RFC 7723
192.0.0.10/32Traversal Using Relays around NAT Anycast · RFC 8155
192.0.0.170/32NAT64/DNS64 Discovery · RFC 8880; RFC 7050, Section 2.2
192.0.0.171/32NAT64/DNS64 Discovery · RFC 8880; RFC 7050, Section 2.2
192.0.2.0/24Documentation (TEST-NET-1) · RFC 5737
192.31.196.0/24AS112-v4 · RFC 7535
192.52.193.0/24AMT · RFC 7450
192.88.99.0/24Deprecated (6to4 Relay Anycast) · RFC 7526
192.88.99.2/326a44-relay anycast address · RFC 6751
192.168.0.0/16Private-Use · RFC 1918
192.175.48.0/24Direct Delegation AS112 Service · RFC 7534
198.18.0.0/15Benchmarking · RFC 2544
198.51.100.0/24Documentation (TEST-NET-2) · RFC 5737
203.0.113.0/24Documentation (TEST-NET-3) · RFC 5737
224.0.0.0/4Multicast · RFC 5771
240.0.0.0/4Reserved · RFC 1112, Section 4
255.255.255.255/32Limited Broadcast · RFC 8190; RFC 919, Section 7

IPv6

::/128Unspecified Address · RFC 4291
::1/128Loopback Address · RFC 4291
::ffff:0.0.0.0/96IPv4-mapped Address · RFC 4291
3fff::/20Documentation · RFC 9637
5f00::/16Segment Routing (SRv6) SIDs · RFC 9602
64:ff9b::/96IPv4-IPv6 Translat. · RFC 6052
64:ff9b:1::/48IPv4-IPv6 Translat. · RFC 8215
100::/64Discard-Only Address Block · RFC 6666
100:0:0:1::/64Dummy IPv6 Prefix · RFC 9780
2001::/23IETF Protocol Assignments · RFC 2928
2001::/32TEREDO · RFC 4380; RFC 8190
2001:1::1/128Port Control Protocol Anycast · RFC 7723
2001:1::2/128Traversal Using Relays around NAT Anycast · RFC 8155
2001:1::3/128DNS-SD Service Registration Protocol Anycast · RFC 9665
2001:2::/48Benchmarking · RFC 5180; RFC Errata 1752
2001:3::/32AMT · RFC 7450
2001:4:112::/48AS112-v6 · RFC 7535
2001:10::/28Deprecated (previously ORCHID) · RFC 4843
2001:20::/28ORCHIDv2 · RFC 7343
2001:30::/28Drone Remote ID Protocol Entity Tags (DETs) Prefix · RFC 9374
2001:db8::/32Documentation · RFC 3849
2002::/166to4 · RFC 3056
2620:4f:8000::/48Direct Delegation AS112 Service · RFC 7534
fc00::/7Unique-Local · RFC 4193; RFC 8190
fe80::/10Link-Local Unicast · RFC 4291
ff00::/8Multicast · RFC 4291

Source: IANA IPv4 and IPv6 Special-Purpose Address Registries (CC0), imported weekly. Multicast blocks come from RFC 5771 and RFC 4291.